Okt29

CCU macht nach Zeitumstellung Probleme? [Update#1]

Kategorien // Inside

CCU macht nach Zeitumstellung Probleme? [Update#1]
Die gestrige Zeitumstellung scheint lt. Forum viele HomeMatic-Zentralen (CCU) aus dem Tritt gebracht zu haben. Auch Neustarts bzw. das Rückspielen eines Backups scheinen keine Lösung zu sein. Zumindest für diejenigen, die den CUx-Daemon installiert und den SSH-Zugang freigeschaltet haben, scheint es aber eine Lösung zu geben.
Der CUx-Daemon erlaubt über die Eingabe einer URL, auf dieser bestimmte Aktionen auszuführen. Da man auf den Service-Bereich des PlugIns ja evtl. nicht mehr zugreifen kann, ist man hierüber in der Lage, die Zentrale in den "Maintenance"-Modus zu setzen:
http://<IP_DER_CCU2>/addons/cuxd/index.ccc?maintenance=
Anschließend benötigt man Zugriff auf die Shell der CCU mit Hilfe eines entsprechenden Hilfsprogrammes wie z.B. Putty oder WinSCP. Auf dieser gibt man dann folgende Befehle ein:
cd /tmp
nohup /bin/ReGaHss -f /etc/rega.conf -l 2 &
Danach sollte die CCU wieder erwartungsgemäß funktionieren.

Quelle: https://homematic-forum.de/forum/viewtopic.php?f=26&t=39766
Inwieweit das Problem mit der Zeitumstellung zu tun hat und welche Faktoren zu welchem Fehlverhalten bei einigen Users geführt hat, kann ich an dieser Stelle nicht sagen, zumal ich anscheinend nicht von diesem Problem betroffen bin. Ich gebe in diesem Artikel daher nur den aktuellen Stand des Forums wieder und verweise auf entsprechende Stellen, die zu einer Problemlösung führen können. Zudem scheint es, dass man ohne installiertem CUx-D und freigeschaltetem SSH-Zugang (Shell) derzeit das Problem wohl nicht lösen kann. Es ist daher ratsam, in diesem Fall das Forum entsprechend weiterzuverfolgen.
Update #1 (20:22):

Nach dutzenden Kommentaren im Forum, hier und in Facebook könnte sich das Problem auch durch einen Reboot nach Mitternacht (00:01) "in Luft auflösen". Daher einfach mal probieren, sollte das Problem derzeit noch bestehen.

Kommentare (20)

  • Christian Bender

    Christian Bender

    29 Oktober 2017 um 12:04
    Hi,
    bei mir haben zwei Schritte geholfen. Recovery Modus mit Downgrade auf Firmware 2.27.8:
    - https://www.google.de/url?sa=t&source=web&rct=j&url=http://www.eq-3.de/Downloads/eq3/pdf_FAQ/Recovery-System.pdf&ved=0ahUKEwiA65n11ZXXAhXCuhoKHeTQCiMQFggxMAM&usg=AOvVaw2-2W239KdfnBuh_YBTpip8
    - http://www.eq-3.de/Downloads/Software/HM-CCU2-Firmware_Updates/HM-CCU2-2.27.8/HM-CCU-2.27.8.tar.gz

    Hatte kein SSH aktiviert und konnte mir daher nur mit dem oben genannten helfen.
    Hoffe es hilft auch euch!

    antworten

  • Thomas Burgherr

    Thomas Burgherr

    29 Oktober 2017 um 12:06
    Ich habe diese Prozedur gemacht - schlussendlich erfolgreich!

    Allerdings musste ich in der Fritzbox den Internet Zugang für den Raspi sperren und nach dem Neustart als ich das PC Datum übernommen habe, hat er sich wieder aufgehängt.

    Schlussendlich habe ich nochmals die Prozedur gemacht und das Datum auf den 29.09.2017 gesetzt und jetzt läufts.

    antworten

  • Stefan Sprenger

    Stefan Sprenger

    29 Oktober 2017 um 12:27
    Bei mir hat das mit dem SSH Zugang funktioniert. Die CCU darf danach nicht wieder neu gestartet werden, sonst tritt der Fehler wieder auf und die Prozedur muss wiederholt werden.

    Falls schon jemand Erfahrung hat mit einer älteren Firmware bitte melden. Ich hab die aktuelle installiert. Hier stimmt jedenfalls irgendetwas nicht.

    antworten

    • Christian Bender

      Christian Bender

      29 Oktober 2017 um 12:59
      Hi Stefan, wie oben schon geschrieben bin ich von 2.29.23 zurück auf 2.27.8 gewechselt. Danach konnte ich die CCU2 wieder nutzen, ohne an der Fritzbox oder am Datum etwas zu ändern. VG Christian

      antworten

  • Ralph Hengen

    Ralph Hengen

    29 Oktober 2017 um 14:01
    Das Zurücksetzen auf Firmware 2.27.8 war auch bei mir erfolgreich.
    Kann man nur hoffen, dass das Problem von den Programmierern von eQ-3 schnell gefixt wird. Sehr ärgerlich, wenn man jetzt zum Zeitpunkt der Zeitumstellung auf Reisen gewesen wäre und die CCU nicht erreichen hätte können!

    antworten

  • Roland

    Roland

    29 Oktober 2017 um 14:24
    Bei mir dasselbe Problem heute. Totalausfall. Es half die Lösung mit SSH und dem nohub Befehl ... (vielen Dank für die Lösung!)
    Auch bei allen Bekannten mit Homematic Anlage dasselbe Problem.
    Sehr ärgerlich!

    antworten

  • Anton Miller

    Anton Miller

    29 Oktober 2017 um 15:28
    SW 2.29.22 und SW 2.29.23 läuft nicht mehr ! Nur die SW 2.27.8 bringt die CCU2 und das dazugehörige Back up wieder zum laufen.
    Meine beiden CCU2 in getrennten Installtionen sind heute morgen ausgefallen.
    Ein Recovery der SW funktioniert zwar gut (neuste Version) , da hat man wieder Zugriff auf die CCU2, jedoch sobald man sein Back Up einspielt läuft die CCU2 in die Wüste , nach dem man die Anmeldedaten eingegeben hat. Ich hoffe das EQ3 super schnell die Sache löst, da alle Änderungen der letzten 3 Monten in den Programmen und SW Änderungen jetzt mit der alten SW Version fehlen, und dies sind bei mir Tage an Arbeit !

    antworten

  • Rosezky

    Rosezky

    29 Oktober 2017 um 15:36
    Hallo Leute!
    Alle Vorgehensweisen aus Foren die sich mit Homematic beschäftigen und vor den selben Problem stehen wie ich und viele Andere Nutzer der CCU2 haben nichts geholfen. SSH funktioniert bei mir nicht da ich SSH auf der CCU2 nicht aktiviert und kein Passwort habe. Über USB Verbindung funktioniert bei mir auch nicht aus welchen Grund auch immer. Recovery funktioniert ebenfalls nicht, bekomme keine Seite im Browser dargestellt nur eine Fehlermeldung das die CCU2 nicht erreichbar ist weil sie der DNS Server nicht kennt!!!!!!!! Dämlicher geht's nicht mehr. Da ich jetzt am Ende meiner Möglichkeiten und der Suche nach Lösungen bin, ist meine Frage hier eigentlich trivial, "Wer kann mir helfen?" oder muss ich das dämliche Ding jetzt zu eQ-3 schicken? Wenn ich das jetzt zurück schicken muss habe ich ein Problem, meine Heizung sowie die dazu gehörigen Pumpen, wird komplett über die CCU2 gesteuert und von außen ist kein Eingriff möglich!!!!!
    Hoffe es hat noch Jemand eine Lösung die funktionieren könnte, vorab herzlichen Dank, RoG

    antworten

  • Reinhardt

    Reinhardt

    29 Oktober 2017 um 16:26
    2 mal CCu2 mit 2.29.13 in Betrieb: kein Problem!

    antworten

  • Klaus Merkt

    Klaus Merkt

    29 Oktober 2017 um 16:38
    Hallo zusammen,
    bei mir hat der Schritt mit dem Recovery geholfen und der Downgrade auf die Version FW 2.27.8
    Danke Christian für den Tipp und die LINKS.

    antworten

  • Beurer

    Beurer

    29 Oktober 2017 um 16:53
    Hallo,
    ich hatte in der privaten CCU2 Cux eingesetzt und inzwischen gelöscht. Es bleiben Reste in der CCU2; denn alle Versuche mit alten Backup´s mit und OHNE Cux bringen keine Erfolg. Also ein Programm für RESTLOSES LÖSCHEN von CUX wäre GUT.
    Noch schlimmer ist, dass eine nigelnagelneue CCU2 mit dem letzten Backup (26.10.) OHNE Cux auch nicht läuft.
    Ich hab da eine Riesenproblem; denn ich glaube die alte CCU2 kann ich vernichten und die neue muss ich neu programmieren. Na ja Gott sei Dank kommunizieren die Komponenten mit einander.
    Bei meinen Kunden gibts das Problem nicht, weil da habe ich den Test mit Cux nicht gemacht. Trotzdem Danke an die vielen guten Hinweise.

    antworten

  • Thomas Zellhofer

    Thomas Zellhofer

    29 Oktober 2017 um 17:24
    Hallo ,
    Ich habbe auch das gleiche Problem aber ich kann mir die FW 2.27.8 nicht runterladen da der Link
    " http://www.eq-3.de/Downloads/Software/HM-CCU2-Firmware_Updates/HM-CCU2-2.27.8/HM-CCU-2.27.8.tar.gz"
    nicht mehr funzt es kommt immer die Meldung Seite kann nicht angzeigt werden.
    Frage wo kann man sich diese Datei noch runterziehen wenn man keine mehr hat???

    Bitte um Hilfe.
    mfg. Thomas

    antworten

  • Johannes Richter

    Johannes Richter

    29 Oktober 2017 um 19:47
    Hallo,

    auch ich bin Opfer des oben beschriebenen Fehlers geworden.
    "CUx-Daemon installiert und den SSH-Zugang" scheint möglich, allerdings wenn ich mich mittels Putty mit der Steuerung verbindet, wird ein Login verlangt.
    Ich kann mich nicht daran erinnern jemals ein Passwort bzw. Benutzernamen vergeben zu haben.

    Kann mir da jemand helfen? Gibt es so etwas wie ein default Login?

    Ich freue mich über jede Hilfe, im Moment geht keine Heizung und vieles andere nicht mehr.

    Johannes

    antworten

  • Stefan Sprenger

    Stefan Sprenger

    29 Oktober 2017 um 20:06
    Hallo Johannes Richter,
    bei mir ging es auch ohne Putty und Passwort.

    http://IP-Adresse der CCU/addons/cuxd/index.ccc?maintenance=

    O Shell command : anklicken und die beiden Befehle nacheinander ausführen.

    cd /tmp
    nohup /bin/ReGaHss -f /etc/rega.conf -l 2 &

    Danach lief wieder alles.

    antworten

  • Stefan Leuther

    Stefan Leuther

    29 Oktober 2017 um 20:48
    Guten Abend, auch ich konnte ohne Putty und Passwort die CCU mittels der vorgenannten Befehle wieder zum Leben erwecken. Vielen Dank für die Hilfe in diesem Forum

    antworten

  • Johannes Richter

    Johannes Richter

    29 Oktober 2017 um 20:49
    bei mir auch!!

    Vielen Dank

    Macht es Sinn auf eine ältere Firmware zu setzen, oder warten was da neues kommt. (solange es keinen Stromausfall gibt funktioniert es ja.)

    antworten

  • Detlef Martens

    Detlef Martens

    30 Oktober 2017 um 07:14
    Das mit der alten Software 2.27.8: war ein ausgezeichneter Tipp, vielen Dank. Allerdings meldete sich eine CCU nicht mit dem Aufruf Ihrer normalen IP Adresse für das Recovery, sondernd hatte sich über DHCP eine andere IP Adresse geholt. Nach der Installation war die CCU dann wieder auf der alten festen IP zu erreichen.
    Vielen Dank für die Hilfe!

    antworten

  • Sven

    Sven

    30 Oktober 2017 um 09:14
    Recovery hat bei mir auch geholfen, vielen Dank.
    Die Frage nach dem Softwareupdate stelle ich mir auch, neue installieren, oder lieber warten?
    Was sagen die Experten?

    antworten

    • HomeMatic-INSIDE

      HomeMatic-INSIDE

      30 Oktober 2017 um 09:42
      Hallo.

      Getreu dem Motto "Never change a running system" lief bei mir noch eine ältere Firmware auf der CCU, die das hier angesprochene Fehlverhalten nicht aufwies. Prinzipiell aktualisiere ich die FW nur, wenn diese Funktionalitäten enthält, die ich unbedingt benötige. In den meisten Fällen sind dies z.B. Unterstützungen für neue HomeMatic-Module, die ich einsetzen möchte. Solange dies bei mir nicht der Fall ist, warte ich mit einem Firmware-Update so lange wie möglich. Da ich das System über ein Wandtablet steuere sind mir Änderungen am WebUI und dergleichen nicht so wichtig, da ich sie eh nicht benutze. Letztendlich muss das jeder für sich selber entscheiden, welche Funktionalität ein Update rechtfertigen. Man sollte sich stets vorher ein Backup erstellen sowie die Installation(en) einer Vorgänger-Firmware aufheben, um ggf. downgraden zu können. Leider hat die Vergangenheit gezeigt, das einige Firmware-Updates mit Problemen behaftet waren. Wenn natürlich jetzt jeder wartet, bevor ein Update eingespielt wird, zeigen sich auch evtl. Fehler nicht - viele davon treten ja nur unter bestimmten Konstellationen auf. In diesem Fall kann man nur hoffen, das eQ-3 dann zeitnah reagiert.

      antworten

Einen eigenen Kommentar verfassen

Du musst auf dieser Seite angemeldet sein, um einen Kommentar für diesen Artikel verfassen zu können.

Kommentare // Blog

Stephan

Stephan

19. November, 2017 |

Hallo zusammen,
ich habe heute das Update installiert. Kurz zuvor hatte ich eine IPKomponente (HmIP-PS) installiert. Diese war nach dem...

Martin Wessel

Martin Wessel

06. November, 2017 |

Ich habe mir soeben einen 6er-Taster bei Haus-Bus.de bestellt.
Hat schon jemand Erfahrungen mit den Geräten?
Klappt die Einbindung...

Kommentare // TecBase

Ralph Punga-Kronbergs

Ralph Punga-Kronbergs

10. April, 2017 |

Kurze Frage: In welchem Wertebereich (Min/Max) befindet sich der Wert der Variable _RANDOM_ nach Generierung?

Gonzalo Jacob

Gonzalo Jacob

31. Dezember, 2016 |

Hallo, Admin !
vielleicht können Sie mir helfen, Ich habe keine Ahnung, wie ich einen Anwesenheitsimulator zum Ein- und Ausschalten...